Audio bar has disappeared

Viewing 15 posts - 1 through 15 (of 16 total)
  • #20082
    theantidoteradio
    Participant

    After the recent WordPress 4.1 update my audio bar has disappeared on my audio posts. What remains is shown below. This is a key part of my site so any solutions would be welcome!

    #20122
    Daniel Tara
    Keymaster

    Along with your update to WordPress 4.1 you need to update the theme to version 1.1.10, significant changes have been made to the audio and video player for this version.

    #20309
    theantidoteradio
    Participant

    Thanks for the response Daniel. I double checked the theme and it is the current version, 1.1.10. The audio bar does appear, but only for a portion of a second. It then reverts to the image that I attached previously. Any other thoughts on a solution?

    #20363
    Daniel Tara
    Keymaster

    Are you using a child theme? Did you apply any modifications to any of these functions?

    • pinboard_register_styles
    • pinboard_enqueue_styles
    • pinboard_enqueue_scripts
    • pinboard_call_scripts
    #20464
    theantidoteradio
    Participant

    The site uses the parent Pinboard theme. There have been no modifications made to any of the functions. If you want to view the site, here’s the address. http://www.theantidoteradio.com/

    #20480
    Daniel Tara
    Keymaster

    The audio player loads fine for me.

    #20564
    theantidoteradio
    Participant

    When clicking on the rotating banner image (or any other reduced page size) to bring up the full page size, the audio bar does not appear.

    #20696
    GreenZebra
    Participant

    Hello Daniel,

    I absolutely adore the Pinboard theme and am using it for a new site. Thank you for creating it and making it available. 🙂

    Would you be able to help me please, as I’m having the same issue with the audio control not showing in the grid. It appears for a fraction of a second and then disappears and is replaced with this:

    It happens in Firefox (V36), Chrome (V40) and IE (V11) on my Win7 Pro 64 PC and also on my Android V4.4 smartphone and tablet.

    Is there an audio player or other plugin we should be using with WP?

    I thought it might be a conflict of some sort so I did a fresh install of WordPress 4.1.1 in a new directory, installed Pinboard 1.1.12 and created an audio post with an embedded mp3. The audio control is not showing correctly. However, it plays the clip when I press the little grey bar under the words “Audio Player”.

    Also, when I go into the post itself, I’m seeing two audio controls, both of which display OK (but look different) and play the clip OK.

    You can see the issues on my test site: http://www.greyfb.com/testwp411/blog/

    I’ve spent three days looking through and tinkering with the code, but can’t figure it out. Would you be able to point me in the right direction, please?

    Many thanks!

    #20743
    joan w
    Participant

    I have the same problem, all my audio players are down. I have only noticed now, as I have only had the time to log into website and update plugins and log out.

    example – http://www.joanwalsh.ie/soldier-boy/

    Any solutions? (The audio was looking good there when the previous issue got resolved last year.)

    thanks, joan

    I don’t know how to paste a screen shot here.

    #20744
    GreenZebra
    Participant

    Hello joan w,

    If it helps, I stumbled on a workaround just this morning. It’s not perfect but it will do.

    Here’s what I did with my test site. In my real site, which is still being built, I copied the relevant code to my child theme and made the changes in the child theme.

    In functions.php, I found the section that refers to mediaelementplayer and removed the curly brackets from the start and end of the mediaelementplayer parameter list. The code now looks like this:

    $(‘.entry-attachment audio, .entry-attachment video’).mediaelementplayer(
    videoWidth: ‘100%’,
    videoHeight: ‘100%’,
    audioWidth: ‘100%’,
    alwaysShowControls: true,
    features: [‘playpause’,’progress’,’tracks’,’volume’],
    videoVolume: ‘horizontal’
    );

    That got an audio control appearing in the grid.

    However, there were still two audio controls showing when I went into the post. To fix that, I edited single.php and removed the call to pinboard_post_audio(). That left only one audio control.

    The gotcha now is that the audio control on the grid looks different to the one that appears in the post. It must have something to do with the browser’s default audio player but I can’t figure out how to change it. If anyone knows, I’d love to hear from you! 🙂

    It also means that for every audio post, you have to embed the audio and make sure it’s attached to the post.

    This seems to work for me. Hope it helps you, too. You can see the result of the changes in my test site http://www.greyfb.com/testwp411/blog/.

    Cheers!

    • This reply was modified 7 years, 3 months ago by GreenZebra.
    #20746
    joan w
    Participant

    Hi Greenzebra. really appreciate you replying.

    thing is i don’t have a child theme, just the regular one. but i will check out what you suggested soon. for a temp fix i may just change all the players to a simple compact one.

    thanks so much. joan

    #20752
    GreenZebra
    Participant

    No problems, Joan, hope it’s of use to you.

    I since discovered that my edit to the mediaelementplayer call caused the menu descriptions to disappear. So, I replaced the entire mediaelementplayer call with this:

    $(‘.wp-audio-shortcode, .wp-video-shortcode’).css(‘visibility’, ‘visible’);

    The menu descriptions re-appeared and I still had a working audio control on the grid.

    All the best with it!

    Cheers ….. Jacquie

    #20792
    HelgeHellcat
    Participant

    Hi Greenzebra.

    I removed only the curly bracket, but now there are some gaps in the grid and
    the infinitely Scrolling doesn’t work. It’s seems that some request (grid with audio types) will never stop.

    What do you mean with “I replaced the entire mediaelementplayer call”?
    Do you replace this entire code block
    $(‘.entry-attachment audio, .entry-attachment video’).mediaelementplayer({
    videoWidth: ’100%’,
    videoHeight: ’100%’,
    audioWidth: ’100%’,
    alwaysShowControls: true,
    features: [‘playpause’,’progress’,’tracks’,’volume’],
    videoVolume: ‘horizontal’
    });

    with
    $(‘.wp-audio-shortcode, .wp-video-shortcode’).css(‘visibility’, ‘visible’);

    ????
    Cheers!

    #20793
    GreenZebra
    Participant

    Hi HelgeHellcat,

    Yes, I replaced the entire code block with the single line.

    I’m using AJAX Links but I just tried it with Infinite Scroll and it’s working OK for me. The audio bars are displaying in the grid and the grid itself is aligned correctly. I did notice white space around the featured images in the grid in Internet Explorer but not in Firefox and Chrome. I’ve yet to figure out why that’s happening.

    I’m also still trying to figure out why the audio bar in the grid looks different to the audio bar in the post but I can live with that at the moment.

    All the best with getting things working for your site!

    Cheers!

    #20797
    HelgeHellcat
    Participant

    Hi,

    all works fine for me.
    “The grid looks different to the audio bar in the post”
    It seems that any kind of javascript will add the second audio bar in the post
    Because if you disable the function pinboard_post_audio() for post (replace “post_password_required” with “is_singular”) the second audio bar will disable.
    So the visible audio bar is not created by the function.

    Who created it? I will search

    Cheers!
    .

Viewing 15 posts - 1 through 15 (of 16 total)

Tagged: ,

You must be logged in to reply to this topic.