Avatar not showing anywhere, still using Gravatar even though it’s disabled

Viewing 3 posts - 1 through 3 (of 3 total)
  • #23957
    XPHut
    Participant

    Hey,

    I’m having an absolute nightmare trying to get this plugin to work for me, I believe it’s my theme/settings not the plugin’s fault.

    I’m using a theme called Kicker and I’m on the latest version of WordPress. I have managed to disable Gravatar from your plugin’s settings and set my own custom avatar which uploads correctly. However, it is not replacing my Gravatar image anywhere. In the admin bar and everywhere else on the site, it’s still showing my Gravatar image.

    I seen you mentioned about replacing the get_avatar function with your own, but I’m unsure where exactly to find this in my theme files.

    Thanks!

    • This topic was modified 9 months, 3 weeks ago by XPHut.
    #23959
    Daniel Tara
    Keymaster

    It’s easy to figure out if the issue is coming from the theme or not: simply activate a different theme and see if the issue persists. If it does, start deactivating plugins one by one until you find the culprit. Start with the plugins that offer memberships or their own avatar replacement functionality which are the ones that usually conflict with One User Avatar. I would leave replacing the get_avatar function as a last resort, as it involves modifying files that are usually overwritten during updates

    #23960
    XPHut
    Participant

    Thanks for the help πŸ™‚

    I have found the culprit.. it’s a social login plugin called ‘miniOrange Social Login, Sharing’. In the settings, I had to go to Registration and uncheck Set Display Picture for User – on User Registration

    The plugin name above is how it appears once installed, on the New Plugin page it appears as ‘WordPress Social Login and Register (Discord, Google, Twitter, LinkedIn)’

    Thought I’d provide this information in case somebody else gets this conflict.

    Thanks for the help πŸ™‚

    • This reply was modified 9 months, 3 weeks ago by XPHut. Reason: Fixed
Viewing 3 posts - 1 through 3 (of 3 total)

Tagged: 

You must be logged in to reply to this topic.