Resizing header & slider, Grid starts after 2 posts

Viewing 5 posts - 1 through 5 (of 5 total)
  • #4709
    griduser
    Participant

    How to:

    1. Make the slider a constant height, automatically re-sizing images if needed?

    2. Make the slider within the width constraints of the main area, and extend the right sidebar upwards to fill up the space?

    3. Resize the header to be not as tall? I went into theme options->layout and changed the default 100px header height to a smaller number but it didn’t make a difference. Then I tried reducing the ‘header image height’ option on the same page from the default of 280px to a smaller number and still no difference.

    4. Fix grid view starting after 2 posts? When slider is enabled, the grid view starts after 2 posts. Two posts are displayed full width in the main area, then below that the grid view starts (2 columns, as expected). When the slider is disabled, the grid view starts immediately. When the slider is enabled, I tried messing with number of full posts to display before grid setting to no effect.

    Here is the website: http://www.classicalislamiclearning.org/blog/

    #4713
    andygreen
    Participant

    I’d also really like to know the answers to the above questions.

    May I ask you griduser, how did you get images to display of posts in your grid. I can’t seem to do so.

    #4716
    griduser
    Participant

    Okay, so I did a bit of php debugging and figured out the answer to #4.

    Short answer: If you haven’t emptied your trash, then the number of sticky posts in the trash will be equal to the number of full posts that show up before the grid. Basically, empty your trash of all sticky posts!

    Long answer:
    The call to get_option( ‘sticky_posts’ ); in esplanade_is_teaser() return the total number of sticky posts, including the ones that are in the trash. When the slider is enabled, this results in $count = $count – count( $sticky ); being negative when it gets to posting the first post in the grid beneath the slider.

    andygreen: You need to select an image as the ‘featured image’ in order for the images to show up. You will see a small link to set as featured image when you are selecting the picture in the add new post page.

    The rest of the questions are still pending, help!!

    #4717
    andygreen
    Participant

    I’ve selected the post as a featured image and it still isn’t showing up. Any idea why?

    andyssportreport.com

    #4838
    Woody
    Participant

    @andygreen
    There are several ways of displaying a photo (Video) in your posts on the home page. Here’s a couple of things to check out:

    When you choose “featured image”, make sure you can see it whilst editing. I think you have forgotten to click update when your finished.

    The other option (which is great) is to look down the right side for “Format” and you will see 10 radio buttons offering choices. Yours should be at default which is “standard”, but try the others because they have some great results.

    I’m still setting my site up but have a look here:
    http://photo-restore.me.uk/

    • This reply was modified 10 years, 5 months ago by Woody.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.