webform results appearing in 'Home Footer' Sidebar – CiviCRM related

Viewing 2 posts - 1 through 2 (of 2 total)
  • #21726
    decdesign
    Participant

    I have been using the CiviCRM plugin with Enlightenment and am working on setting up a Contribution page where people can donate money through the website. using this CiviCRM Contribution feature I have been able to embed a Contribution webform into a wp Page using CiviCRM shortcode. All is fine until I submit a test contribution — the resulting Page replicates the resulting webform into the custom footer i set up for the website in Appearance -> Widgets -> Home Footer -> Custom Query (List->4 Columns->Multiple Pages), clobbering the hyperlinks i normally have with the webform results.

    I.e., once I submit the Contribution webform I see the resulting “Thank you” webform result 5 places in the Page.. in the main page content (<div class=”container”..) and 4 times in the custom footer/Enlightenment “Sidebar”. When viewing the page source, ‘<div id=”crm-container”‘ appears 5 times, each inside ‘<div class=entry-content’ — once inside ‘<div class=”container”‘ and 4 times in ‘<div id=”sidebar-footer”‘

    Here is a grab of the first 2 columns in the footer/Sidebar before and after submitting the webform..
    a part of the footer as it appears before contribution submission: http://imgur.com/UaFsXKK

    same part of the wp footer as it appears after submission.. http://imgur.com/Sujo2ht

    Seems like the source of the problem has something to do with CiviCRM not expecting there to be Pages embedded in the footer/Home Footer Sidebar in the bottom of the page.
    Any ideas for a workaround? I would be fine with disabling the sidebars altogether the webform and resulting page if it would allow be to get Contribution page going.. not really sure how to go about this tho…

    • This topic was modified 7 years, 2 months ago by decdesign. Reason: didn't finish creating accurate title
    #21741
    decdesign
    Participant

    Follow and solution— The problem I’m having seems definitely like a conflict between Enlightenment and CiviCRM. Using the Multiple Themes wp plugin I was able to change the Theme to be wf’s Twenty Fifteen for just the ?page=CiviCRM pages and problem is solved. The look & feel for the Contribution pages/webforms are different but at this point I don’t care – function over form.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.